
 

EUROPEAN COMMISSION 

EUROSTAT 

 

Directorate E: Sectoral and regional statistics 

Unit E-2: Environmental statistics and accounts; sustainable development 

 

 

 

 

 

 

INCA TOOL 

Installation Guide 

Eurostat – Unit E2 

 

 

 

 

Task force on ecosystem accounting 

 

Version 1.0.0 

May 2023 

 



 

1 

 

Contents 

1. Windows ............................................................................................................................. 2 

1.1. Download QGIS .......................................................................................................... 2 

1.2. Install the plugin .......................................................................................................... 2 

1.3. Installation of additional required Python packages .................................................... 4 

1.4. Restart QGIS .............................................................................................................. 10 

1.5. Troubleshooting ......................................................................................................... 10 

2. MacOS .............................................................................................................................. 13 

2.1. Install QGIS ............................................................................................................... 13 

2.2. Install the plugin ........................................................................................................ 13 

2.3. Restart QGIS .............................................................................................................. 14 

3. Linux ................................................................................................................................. 15 

3.1. Install QGIS ............................................................................................................... 15 

3.2. Install dependencies ................................................................................................... 15 

3.3. Install the plugin ........................................................................................................ 15 

3.4. Restart QGIS .............................................................................................................. 16 

4. Getting help ....................................................................................................................... 16 

 

  



 

2 

 

1. Windows 

On a Windows system, the plugin and all required extra packages can be installed 

automatically from QGIS itself.  If QGIS is installed in a directory which requires 

administrator permissions (such as C:\Program Files), you will also need administrator 

permissions for the initial plugin installation, where we need to install a number of extra 

QGIS components.  Later updates of the plugin will not require administrator permissions 

anymore. 

 

1.1. Download QGIS 

If QGIS is not yet installed on your system, install QGIS 3.28 (LTR) from qgis.org.   

• If QGIS is already installed on your system, we recommend upgrading to the latest 

LTR version. 

• Some extra QGIS components must be installed in order to use the INCA tool. If 

QGIS was installed for you by a system administrator, and you do not have the 

required permissions to update this installation, you should install a version of QGIS 

in your user directory, or ask your system administrator to perform the installation for 

you. 

If you do not have administrator privileges, we recommend downloading the OSGeo4W 

Network Installer, which will allow you to install QGIS in a personal directory without 

administrator rights. For an easy installation procedure, choose the Express Install. 

Note: Installing the plugin from an older version of QGIS for windows may lead to 

compatibility problems. 

 

1.2. Install the plugin 

In the ‘Plugins’ menu, click ‘Manage and Install Plugins…’. Choose “Install from ZIP”, 

select the INCA plugin zip file, and click ‘Install Plugin’. QGIS may show a ‘Security 

warning’ asking you whether you trust the source of the zip file. Click ‘Yes’ to continue the 

installation. 
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If some of the Python packages required for INCA are not available in your QGIS installation, 

the plugin will detect this and start the installation: 

 

Click OK to continue with the installation and exit QGIS.  If administrator privileges are 

required to access your QGIS installation directory, a Windows User Account Control dialog 

may appear, asking you if you want to allow ‘OSGeo4W Setup’ to make changes to you 

device.  Click Yes to proceed with the installation. 

Note: If the INCA Installation window does not appear, go to the ‘Installed’ section of the 

‘Manage Plugins’ window. If the INCA plugin is enabled (box is checked), disable it. Now 

click the checkbox again to enable INCA. The installation should now proceed. 
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Figure 1: Installed plugins.  Use the checkbox to (re-)enable INCA if the installation does not start automatically. 

Now, INCA will start the OSGeo4W setup tool to install the additional required packages. 

 

1.3. Installation of additional required Python packages 

In the first step, select the ‘Advanced Install’, click Next. 

 

In the next screen, keep the default option ‘Install from Internet’.  Click Next. 
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In the next screen, keep the pre-filled Root Directory (this is the installation directory of the 

QGIS you are running, and may differ from the one shown in the screenshot below). Click 

Next. 
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Next, you can keep the proposed ‘Local Package Directory’ and ‘Start menu name. Click 

Next. 

 

Next, set up the internet connection.  Most users can keep the default ‘Use System Proxy 

Settings’. On a secured network, you may have to configure an HTTP Proxy to download the 

extra packages (contact your IT support if you don’t know the correct settings).  
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In the next screen, keep the proposed Download Site (or choose one yourself in case none is 

selected).  If the list of Available Download Sites is empty, see the Troubleshooting section 

below for a solution. 

 

We now arrive at the ‘Select Packages’ screen. The INCA plugin has already selected the 

packages it needs, so you do not need to change anything here. Click Next. 
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Now, the setup program will likely show a warning about unmet dependencies, such as in the 

screen shot below.  Keep the check next to “Install these packages to meet dependencies 

(RECOMMENDED)” and click Next. 

 

The setup program now downloads and installs the required packages. 
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After some time, the following screen will indicate we are done.  Click Finish. 

 

 

Now the OSGeo4W Setup is finished, and you can start QGIS again to complete the plugin 

installation.  The plugin requires a few more Python packages, such as the INCA core 

package, which can’t be installed using the OSGeo4W Setup utility.  INCA will use Python’s 

built-in pip tool to install these.  If you need to use a proxy to access the web, check ‘Use 

HTTP/FTP Proxy’ and fill out the required details.  Click ‘Ok’ to confirm the installation. 
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The installation of these final packages should take only a minute.  Then, plugin installation is 

complete and the plugin is ready for use. 

 

1.4. Restart QGIS 

If an older version of the INCA plugin was already installed before, you are now asked to 

restart QGIS. 

 

1.5. Troubleshooting 

This section provides solutions for a few common installation issues. 

In-use files detected 

 

During the OSGeo4W setup, an error sometimes appears, telling you that installation can’t 

proceed because a file is in use.  There are two different cases where this happens. 

1. The file in use is the OSGeo4W setup utility itself (osgeo4w-setup.exe).  In this case, 

the error message will mention “Unable to extract /bin/osgeo4w-setup.exe”: 

 
This means that the setup utility is updating itself, which is sometimes necessary.  In 

this case, you should press Continue.  If the installation completes without further 

errors, follow the instructions from the dialog, and reboot your computer before using 

QGIS again. 

2. The ‘in-use’ file is any other QGIS file.  There are two common causes for this error: 

• A version of QGIS is still running.  Make sure all instances of QGIS are closed 

before trying ‘Continue’. 
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• If there is no running instance of QGIS, the cause of the error is likely that QGIS is 

installed in a directory where administrator rights are required to make changes, 

such as ‘C:\Program Files\QGIS x.y.z’, but OSGeo4W Setup is running without 

administrator rights.  In this case, you should abort the current installation, by 

clicking ‘Cancel’ in the main OSGeo4W Setup window: 

 
Next, restart QGIS with admin rights, by right-clicking the shortcut and choosing 

‘Run as administrator’, and continue the plugin installation. 
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No Available Download Sites 

 

If the list of available download sites in the OSGeo4W setup utility is empty, the cause may 

be a Windows configuration setting.  Click ‘Cancel’ to close OSGeo4W setup, and take the 

following steps to enable the installer: 
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1. Go to Windows’ ‘Control Panel’ and open ‘Internet Options’. 

2.   In the ‘Advanced’ tab, scroll to the bottom and make sure ‘Use TLS 1.2’ is checked 

(adjusting this setting may require Administrator privileges). 

  
3. Click OK to confirm.  Now restart QGIS to resume the INCA installation. 

No administrator privileges 

If your QGIS installation is in a directory which requires administrator rights, but your 

account is not an Administrator, you will not be able to install the plugin for the existing 

QGIS installation without help from your system administrator.  As a workaround, you can 

download the QGIS installer from https://qgis.org, and install a version of QGIS in a directory 

where you do have full access rights, such as C:\Users\<yourusername>. 

 

2. MacOS 

2.1. Install QGIS 

Install QGIS 3.22 LTR or later from https://qgis.org.  

2.2. Install the plugin 

In the ‘Plugins’ menu, click ‘Manage and Install Plugins…’. Choose “Install from ZIP”, 

select the INCA plugin zip file, and click ‘Install Plugin’. QGIS may show a ‘Security 

warning’ asking you whether you trust the source of the zip file. Click ‘Yes’ to continue the 

installation. 

https://qgis.org/
https://qgis.org/
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The plugin will then ask to install some extra packages using pip.  Click ‘OK’ to continue. 

 

This step concludes the installation 

2.3. Restart QGIS 

If you are upgrading from a previous INCA version, you are asked to restart QGIS so the 

INCA version can be used. 
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3. Linux  

3.1. Install QGIS 

Install QGIS 3.22 (LTR) or later. 

 

3.2. Install dependencies 

The INCA plugin requires a number of Python packages which are not included with a default 

QGIS installation.  You should install these packages in the Python environment of your 

QGIS installation before installing the plugin.  The required third-party packages are: 

• geopandas 

• rasterio 

• scipy 

• scikit-learn 

• Rtree 

• pyshp 

• importlib-metadata 

• pip 

• setuptools 

Depending on your Linux distribution, the best way to obtain these packages might be to 

install them  

• using your distribution’s package manager (such as apt on Debian-based 

distributions), or  

• using pip, or 

• a combination of both. 

After installing these third-party packages, you need to install the inca core package itself.  

Using the python interpreter of your QGIS installation, run the following command: 

$ python -m pip install 

inca@https://marvintest.vito.be/~danckaet/inca-0.0.6-py3-none-

any.whl 

If you need to use a HTTP proxy, add the option  

--proxy http://<username>:<password>@<proxy-host>:<proxy-port> 

to the command above. 

 

3.3. Install the plugin 

In the ‘Plugins’ menu, click ‘Manage and Install Plugins…’.  Choose “Install from ZIP”, 

select the INCA plugin zip file, and click ‘Install Plugin’.  QGIS may show a ‘Security 

warning’ asking you whether you trust the source of the zip file.  Click ‘Yes’ to continue the 



 

16 

 

installation.  If all dependencies from the previous step were installed, the plugin is now ready 

to use. 

 

3.4. Restart QGIS 

If a previous version of inca was already installed on your system, you should restart QGIS to 

make sure the newly installed version of the inca core package is used. 

4. Getting help 

If you run into issues during plugin installation, contact support@inca.vito.be for help.  To 

help diagnose the problem, please copy the contents of the QGIS Log Messages window 

(click ‘View’ > ‘Panels’ > ‘Log Messages’, and copy the contents of the tab ‘General’), and 

the contents of the ‘About QGIS’ window (click ‘Help’ > ‘About’). 

 

mailto:support@inca.vito.be
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